PAT 乙级 1038. 统计同成绩学生(20) C++版

本题要求读入N名学生的成绩,将获得某一给定分数的学生人数输出。

输入格式:

输入在第1行给出不超过105的正整数N,即学生总人数。随后1行给出N名学生的百分制整数成绩,中间以空格分隔。最后1行给出要查询的分数个数K(不超过N的正整数),随后是K个分数,中间以空格分隔。

输出格式:

在一行中按查询顺序给出得分等于指定分数的学生人数,中间以空格分隔,但行末不得有多余空格。

输入样例:

10
60 75 90 55 75 99 82 90 75 50
3 75 90 88

输出样例:

3 2 0

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
#include <iostream>

using namespace std;

int main() {
int *score = new int[101];
int n = 0;
cin >> n;

for (int i = 0; i < n; i++) {
int temp = 0;
cin >> temp;
score[temp]++;
}
int k = 0;
cin >> k;
for (int i = 0; i < k - 1; i++) {
int temp = 0;
cin >> temp;
cout << score[temp] << " ";
}
int temp = 0;
cin >> temp;
cout << score[temp];

delete[] score;

}