PAT 1116. Come on! Let’s C (20)

“Let’s C” is a popular and fun programming contest hosted by the College of Computer Science and Technology, Zhejiang University. Since the idea of the contest is for fun, the award rules are funny as the following: 0. The Champion will receive a “Mystery Award” (such as a BIG collection of students’ research papers…). 1. Those who ranked as a prime number will receive the best award – the Minions (小黄人)! 2. Everyone else will receive chocolates. Given the final ranklist and a sequence of contestant ID’s, you are supposed to tell the corresponding awards.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=10000), the total number of contestants. Then N lines of the ranklist follow, each in order gives a contestant’s ID (a 4-digit number). After the ranklist, there is a positive integer K followed by K query ID’s.

Output Specification:

For each query, print in a line “ID: award” where the award is “Mystery Award”, or “Minion”, or “Chocolate”. If the ID is not in the ranklist, print “Are you kidding?” instead. If the ID has been checked before, print “ID: Checked”.

Sample Input:

6
1111
6666
8888
1234
5555
0001
6
8888
0001
1111
2222
8888
2222

Sample Output:

8888: Minion
0001: Chocolate
1111: Mystery Award
2222: Are you kidding?
8888: Checked
2222: Are you kidding?

根据给出的要查询的ID,得到它的名词,根据名词得到结果

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
#include <cstdio>
#include <algorithm>

using namespace std;

int isPrime(int num) {
for (int i = 2; i * i <= num; i++) {
if (num % i == 0) {
return 0;
}
}
return 1;
}

int main() {
int n = 0;
scanf("%d", &n);
int rank[10000];
fill(rank, rank + 10000, -1);
for (int i = 1; i <= n; i++) {
int t = 0;
scanf("%d", &t);
rank[t] = i;
}
int k = 0;
scanf("%d", &k);
int checked[10000];
fill(checked, checked + 10000, 0);
for (int i = 0; i < k; i++) {
int query = 0;
scanf("%d", &query);

if (rank[query] == -1) {
printf("%04d: Are you kidding?\n", query);
} else {
if (checked[query] == 1) {
printf("%04d: Checked\n");
} else if (rank[query] == 1) {
printf("%04d: Mystery Award\n", query);
checked[query] = 1;
} else {
if (isPrime(rank[query])) {
printf("%04d: Minion\n", query);
checked[query] = 1;
} else {
printf("%04d: Chocolate\n", query);
checked[query] = 1;
}
}
}

}
return 0;
}