PAT 1067. Sort with Swap(0,*) (25)

Given any permutation of the numbers {0, 1, 2,…, N-1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way: Swap(0, 1) => {4, 1, 2, 0, 3} Swap(0, 3) => {4, 1, 2, 3, 0} Swap(0, 4) => {0, 1, 2, 3, 4} Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (<=105) followed by a permutation sequence of {0, 1, …, N-1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10 3 5 7 2 6 4 9 0 8 1

Sample Output:

9

这里当0处于0号位置时,查找要花费比较多得时间,所以用一个变量记录上次查找到得位置,那么下次查找就从这个记录的位置开始查找就可以了

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
#include <cstdio>
#include <algorithm>

using namespace std;

int main() {
int n = 0;
scanf("%d", &n);
int *pos = new int[n];
int unsort = 0;
for (int i = 0; i < n; i++) {
int num = 0;
scanf("%d", &num);
pos[num] = i;
if (i != pos[i] && i != 0) unsort++;
}
int cnt = 0, k = 0;
while (unsort > 0) {
if (pos[0] != 0) {
swap(pos[0], pos[pos[0]]);
cnt++;
unsort--;
} else {
while (k < n) {
if (k != pos[k]) {
swap(pos[0], pos[k]);
cnt++;
break;
}
k++;
}
}
}
printf("%d\n", cnt);
delete[] pos;
return 0;
}