PAT 甲级 1022. Digital Library (30) C++版

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID’s.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title – a string of no more than 80 characters;
  • Line #3: the author – a string of no more than 80 characters;
  • Line #4: the key words – each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher – a string of no more than 80 characters;
  • Line #6: the published year – a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers. After the book information, there is a line containing a positive integer M (<=1000) which is the number of user’s search queries. Then M lines follow, each in one of the formats shown below:

1: a book title
2: name of an author
3: a key word
4: name of a publisher
5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID’s in increasing order, each occupying a line. If no book is found, print “Not Found” instead.

Sample Input:

3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:

1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

题目看起来信息量比较多,但简的来说,查找某个书的id,查找的条件可能是author, title或者其他的信息。使用map可以很方便的处理这个查找的过程,我这里创建几个map<string, set>类型的变量,用来存储某个author对应的id的集合,即某个作者可能写了多本书;某个title对应的id的集合,某个publisher对应的id的集合, etc。 在查询的时候,匹配查询条件,输出map中对应的书的所有id。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
#include <string>
#include <iostream>
#include <map>
#include <set>

using namespace std;

void print_ids(set<int> &ids) {
bool flag = false;
for (auto it = ids.begin(); it != ids.end(); it++) {
printf("%07d\n", *it);
flag = true;
}
if (!flag) printf("Not Found\n");
}

int main() {
int n = 0, m = 0, k = 0, id = 0, publish_year = 0;
string title, author, publisher, keyword;
scanf("%d", &n);
map<string, set<int>> author_m, title_m, publisher_m, publish_year_m, keyword_m;
for (int i = 0; i < n; i++) {
scanf("%d", &id);
getchar();
getline(cin, title);
getline(cin, author);
while (cin >> keyword) {
keyword_m[keyword].insert(id);
if (getchar() == '\n') break;
}
getline(cin, publisher);
scanf("%d", &publish_year);
author_m[author].insert(id);
title_m[title].insert(id);
publisher_m[publisher].insert(id);
publish_year_m[to_string(publish_year)].insert(id);
}

scanf("%d", &m);
for (int i = 0; i < m; i++) {
scanf("%d: ", &k);
string str;
getline(cin, str);
printf("%d: %s\n", k, str.c_str());
if (k == 1) {
print_ids(title_m[str]);
} else if (k == 2) {
print_ids(author_m[str]);
} else if (k == 3) {
print_ids(keyword_m[str]);
} else if (k == 4) {
print_ids(publisher_m[str]);
} else {
print_ids(publish_year_m[str]);
}
}

return 0;

}