PAT 1107. Social Clusters (30)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A “social cluster” is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (<=1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format: Ki: hi[1] hi[2] … hi[Ki] where Ki (>0) is the number of hobbies, and hi[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

用并查集去处理

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
#include <cstdio>
#include <vector>
#include <algorithm>

using namespace std;

int getFather(int *father, int x) {
if (father[x] == x) return x;
return getFather(father, father[x]);
}

int main() {
int n = 0;
scanf("%d", &n);
vector<vector<int> > hobbies(1001);
for (int i = 1; i <= n; i++) {
int k = 0;
scanf("%d:", &k);
for (int j = 0; j < k; j++) {
int t = 0;
scanf("%d", &t);
hobbies[t].push_back(i);

}

}

int *father = new int[n + 1];
for (int i = 0; i <= n; i++) father[i] = i;
for (int i = 1; i <= 1000; i++) {
if (hobbies[i].size() != 0) {
int v = getFather(father, hobbies[i][0]);
for (int j = 1; j < hobbies[i].size();
j++) {
int u = getFather(father, father[hobbies[i][j]]);
if (v != u) father[u] = v;
}
}
}

for (int i = 1; i <= n; i++) {
father[i] = getFather(father, i);
}

int *cluster = new int[n + 1];
fill(cluster, cluster + n + 1, 0);
for (int i = 1; i <= n; i++) {
cluster[father[i]]++;
}

vector<int> ans;
for (int i = 1; i <= n; i++) {
if (cluster[i] > 0) ans.push_back(cluster[i]);
}
sort(ans.begin(), ans.end());

printf("%ld\n", ans.size());
for (auto i = ans.rbegin(); i != ans.rend(); i++) {
if (i != ans.rbegin()) printf(" ");
printf("%d", *i);

}
delete[] cluster;
delete[] father;
return 0;
}