PAT 甲级 1009. Product of Polynomials (25) C++版

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < … < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 3 3.6 2 6.0 1 1.6

多项式乘以多项式,多项式的指数最多是1000,则多项式的乘积指数最大应该不超过2000,用数组的下标表示指数,方便计算

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
#include <cstdio>

int main() {
double poly[1001] = {0.0}, result[2001] = {0.0}, an = 0;
int k = 0, n = 0, cnt = 0;
scanf("%d", &k);
for (int i = 0; i < k; i++) {
scanf("%d %lf", &n, &an);
poly[n] = an;
}
scanf("%d", &k);
for (int i = 0; i < k; i++) {
scanf("%d %lf", &n, &an);
for (int i = 0; i <= 1000; i++) {
result[i + n] += poly[i] * an;
}
}

for (int i = 2000; i >= 0; i--) {
if (result[i] != 0.0) {
cnt++;
}
}
printf("%d", cnt);

for (int i = 2000; i >= 0; i--) {
if (result[i] != 0.0) {
printf(" %d %.1f", i, result[i]);
}
}

return 0;
}