PAT 1077. Kuchiguse (20)

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker’s personality. Such a preference is called “Kuchiguse” and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle “nyan~” is often used as a stereotype for characters with a cat-like personality:

  • Itai nyan~ (It hurts, nyan~)
  • Ninjin wa iyada nyan~ (I hate carrots, nyan~)

Now given a few lines spoken by the same character, can you find her Kuchiguse?

Input Specification:

Each input file contains one test case. For each case, the first line is an integer N (2<=N<=100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character’s spoken line. The spoken lines are case sensitive.

Output Specification:

For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write “nai”.

Sample Input 1:

3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~

Sample Output 1:

nyan~

Sample Input 2:

3
Itai!
Ninjinnwaiyada T_T
T_T

Sample Output 2:

nai

找到每个字符串都有的后缀,从每个字符串的最后开始检查

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
#include <stack>
#include <cstring>
#include <iostream>
#include <vector>

using namespace std;

stack<char> suffix(vector<string> v) {
stack<char> s;
for (auto i = v[0].rbegin(); i != v[0].rend(); i++) {
s.push(*i);
for (int j = 1; j < v.size(); j++) {
if (v[j].size() >= s.size() && v[j][v[j].size() - s.size()] != s.top()) {
s.pop();
return s;
}
}
}
return s;
}

int main() {
int n = 0;
cin >> n;
getchar();
vector<string> v(n);
for (int i = 0; i < n; i++) {
getline(cin, v[i]);
}
stack<char> s = suffix(v);
if (s.size() == 0) {
cout << "nai";
}
while (s.size() != 0) {
cout << s.top();
s.pop();
}
return 0;
}