PAT 乙级 1003. 我要通过!(20) Java版

“答案正确”是自动判题系统给出的最令人欢喜的回复。本题属于PAT的“答案正确”大派送 —— 只要读入的字符串满足下列条件,系统就输出“答案正确”,否则输出“答案错误”。 得到“答案正确”的条件是: 1. 字符串中必须仅有P, A, T这三种字符,不可以包含其它字符; 2. 任意形如 xPATx 的字符串都可以获得“答案正确”,其中 x 或者是空字符串,或者是仅由字母 A 组成的字符串; 3. 如果 aPbTc 是正确的,那么 aPbATca 也是正确的,其中 a, b, c 均或者是空字符串,或者是仅由字母 A 组成的字符串。 现在就请你为PAT写一个自动裁判程序,判定哪些字符串是可以获得“答案正确”的。

输入格式:

每个测试输入包含1个测试用例。第1行给出一个自然数n (<10),是需要检测的字符串个数。接下来每个字符串占一行,字符串长度不超过100,且不包含空格。

输出格式:

每个字符串的检测结果占一行,如果该字符串可以获得“答案正确”,则输出YES,否则输出NO。

输入样例:

8
PAT
PAAT
AAPATAA
AAPAATAAAA
xPATx
PT
Whatever
APAAATAA

输出样例:

YES
YES
YES
YES
NO
NO
NO
NO

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
import java.util.Scanner;

public class Main {

public static void main(String[] args) {
Scanner in = new Scanner(System.in);
int n = in.nextInt();
in.nextLine();
String[] s = new String[n];

for (int i = 0; i < n; i++) {
boolean isOther = false;
s[i] = in.nextLine();
for (int j = 0; j < s[i].length(); j++) {
if (s[i].charAt(j) != 'P' && s[i].charAt(j) != 'A' && s[i].charAt(j) != 'T') {
System.out.println("NO");
isOther = true;
break;
}
}

if (!isOther) {
//if all the character are only P A and T
if (isTrue(s[i])) {
System.out.println("YES");
} else {
System.out.println("NO");
}

}
}
in.close();
}

private static boolean isTrue(String s) {
//refine the a b and c three substring.
int p = s.indexOf('P');
int t = s.indexOf('T');

if (p > t) {
return false;
}

String a, b, c;
if (p != -1) {
a = s.substring(0, p);
} else {
return false;
}

if (t != -1) {
c = s.substring(t + 1);
} else {
return false;
}

b = s.substring(p + 1, t);

if (a.contains("P") || a.contains("T") || b.contains("T") || b.contains("P") || c.contains("P") || c.contains("T")) {
return false;
}

if (c.length() < a.length()) {
return false;
}

//it assume that the substring not have other character.
if (b.length() == 0) {
// b must not be empty.
return false;
}


if (a.equals(c) && a.equals("")) {
return true;
}

int times = 0;
for (int i = 0; i <= c.length() - a.length(); i += a.length()) {
if (a.equals(c.substring(i, i + a.length()))) {
times++;
}
}

return times == b.length();
}
}