PAT 甲级 1150 Travelling Salesman Problem(25 分) C++版

The “travelling salesman problem” asks the following question: “Given a list of cities and the distances between each pair of cities, what is the shortest possible route that visits each city and returns to the origin city?” It is an NP-hard problem in combinatorial optimization, important in operations research and theoretical computer science. (Quoted from “https://en.wikipedia.org/wiki/Travelling_salesman_problem“.) In this problem, you are supposed to find, from a given list of cycles, the one that is the closest to the solution of a travelling salesman problem.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of cities, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format City1 City2 Dist, where the cities are numbered from 1 to N and the distance Dist is positive and is no more than 100. The next line gives a positive integer K which is the number of paths, followed by K lines of paths, each in the format: n C​1​​ C​2​​ … C​n​​ where n is the number of cities in the list, and C​i​​’s are the cities on a path.

Output Specification:

For each path, print in a line Path X: TotalDist (Description) where X is the index (starting from 1) of that path, TotalDistits total distance (if this distance does not exist, output NA instead), and Description is one of the following:

  • TS simple cycle if it is a simple cycle that visits every city;
  • TS cycle if it is a cycle that visits every city, but not a simple cycle;
  • Not a TS cycle if it is NOT a cycle that visits every city.

Finally print in a line Shortest Dist(X) = TotalDist where X is the index of the cycle that is the closest to the solution of a travelling salesman problem, and TotalDist is its total distance. It is guaranteed that such a solution is unique.

Sample Input:

6 10
6 2 1
3 4 1
1 5 1
2 5 1
3 1 8
4 1 6
1 6 1
6 3 1
1 2 1
4 5 1
7
7 5 1 4 3 6 2 5
7 6 1 3 4 5 2 6
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 2 5 4 3 1
7 6 3 2 5 4 1 6

Sample Output:

Path 1: 11 (TS simple cycle)
Path 2: 13 (TS simple cycle)
Path 3: 10 (Not a TS cycle)
Path 4: 8 (TS cycle)
Path 5: 3 (Not a TS cycle)
Path 6: 13 (Not a TS cycle)
Path 7: NA (Not a TS cycle)
Shortest Dist(4) = 8

判断给出的一条路径是否是旅行商回路。 先判断这条路径是否形成了一个环且是否图中每个点都被访问过,如果不满足这两个条件,则它便不是一个旅行商环。 再判断这条路径是否是一个简单旅行商环,即是否图中每个点都仅被访问过一次。 最后输出最短路径和路径编号。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
#include <cstdio>
#include <algorithm>
#include <vector>
#include <map>

using namespace std;

int graph[210][210];
const int inf = 99999;

void init_graph() {
for (int i = 0; i < 210; i++) {
fill(graph[i], graph[i] + 210, inf);
}
}

bool is_cycle(int *arr, int m, int n, int &path_dist) {
int start = arr[0];
vector<int> cnt(n + 1, 0);
cnt[arr[0]] += 1;
for (int i = 1; i < m; i++) {
cnt[arr[i]] += 1;
if (graph[arr[i]][start] == inf) {
path_dist = -1;
return false;
} else {
path_dist += graph[arr[i]][start];
start = arr[i];
}
}
for (int i = 1; i <= n; i++) {
if (cnt[i] == 0)
return false;
}
return arr[0] == arr[m - 1];
}

bool is_simple_cycle(int *arr, int m, int n) {
vector<int> cnt(n + 1, 0);
for (int i = 1; i < m; i++) {
cnt[arr[i]]++;
}
for (int i = 1; i <= n; i++) {
if (cnt[i] > 1) return false;
}
return true;
}

int main() {
init_graph();
int n = 0, m = 0, a = 0, b = 0, dist = 0, k = 0;
scanf("%d %d", &n, &m);
for (int i = 0; i < m; i++) {
scanf("%d %d %d", &a, &b, &dist);
graph[a][b] = graph[b][a] = dist;
}
scanf("%d", &k);
map<int, int> short_path;
for (int i = 0; i < k; i++) {
scanf("%d", &m);
int *arr = new int[m];
for (int j = 0; j < m; j++) {
scanf("%d", &arr[j]);
}
int path_dist = 0;
if (!is_cycle(arr, m, n, path_dist)) {
if (path_dist == -1) {
printf("Path %d: NA (Not a TS cycle)\n", i + 1);
} else {
printf("Path %d: %d (Not a TS cycle)\n", i + 1, path_dist);
}
} else {
short_path[path_dist] = i + 1;
if (is_simple_cycle(arr, m, n)) {
printf("Path %d: %d (TS simple cycle)\n", i + 1, path_dist);
} else {
printf("Path %d: %d (TS cycle)\n", i + 1, path_dist);
}
}
}
printf("Shortest Dist(%d) = %d\n", short_path.begin()->second, short_path.begin()->first);
return 0;
}