PAT 甲级 1148 Werewolf - Simple Version(20 分) C++版

Werewolf(狼人杀) is a game in which the players are partitioned into two parties: the werewolves and the human beings. Suppose that in a game,

  • player #1 said: “Player #2 is a werewolf.”;
  • player #2 said: “Player #3 is a human.”;
  • player #3 said: “Player #4 is a werewolf.”;
  • player #4 said: “Player #5 is a human.”; and
  • player #5 said: “Player #4 is a human.”.

Given that there were 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liers. Can you point out the werewolves? Now you are asked to solve a harder version of this problem: given that there were N players, with 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liers. You are supposed to point out the werewolves.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (5≤N≤100). Then N lines follow and the i-th line gives the statement of the i-th player (1≤i≤N), which is represented by the index of the player with a positive sign for a human and a negative sign for a werewolf.

Output Specification:

If a solution exists, print in a line in ascending order the indices of the two werewolves. The numbers must be separated by exactly one space with no extra spaces at the beginning or the end of the line. If there are more than one solution, you must output the smallest solution sequence – that is, for two sequences A=a[1],…,a[M] and B=b[1],…,b[M], if there exists 0≤k<M such that a[i]=b[i] (i≤k) and a[k+1]<b[k+1], then A is said to be smaller than B. In case there is no solution, simply print No Solution.

Sample Input 1:

5
-2
+3
-4
+5
+4

Sample Output 1:

1 4

Sample Input 2:

6
+6
+3
+1
-5
-2
+4

Sample Output 2 (the solution is not unique):

1 5

Sample Input 3:

5
-2
-3
-4
-5
-1

Sample Output 3:

No Solution

首先指定n个人中有两个狼人,用sign数组表示每一号玩家的状态(人用1表示或者狼人用-1表示),然后for循环遍历所有玩家,寻找说谎的玩家,即如果sign数组中指定的某个玩家的状态和当前玩家说的某个玩家的状态不一致,则当前玩家在说谎。最后判断说谎的人数是否等于2,并且这两个说谎的玩家里面,是否一个是人一个是狼人。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
#include <cstdio>
#include <vector>
#include <cmath>

using namespace std;

int main() {
int n = 0;
scanf("%d", &n);
vector<int> v(n + 1);
for (int i = 1; i <= n; i++) {
scanf("%d", &v[i]);
}
for (int i = 1; i <= n; i++) {
for (int j = i + 1; j <= n; j++) { // two wolfware
vector<int> sign(n + 1, 1), lier;
sign[i] = sign[j] = -1;
for (int k = 1; k <= n; k++) {
if (sign[abs(v[k])] * v[k] < 0) { // sb lie
lier.push_back(k);
}
}
if (lier.size() == 2 && sign[lier[0]] * sign[lier[1]] < 0) {
printf("%d %d\n", i, j);
return 0;
}
}
}
printf("No Solution\n");
return 0;
}