PAT 甲级 1028 List Sorting(25 分) C++版

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤10​5​​) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student’s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID’s; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID’s in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

列表排序

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
#include <cstdio>
#include <cstdlib>
#include <cstring>

using namespace std;

struct Record {
int id, grade;
char *name = new char[9];
};

void sortByThree(struct Record *records, int n) {
qsort(records, n, sizeof(records[0]), [](const void *a, const void *b) {
const struct Record arg1 = *static_cast<const struct Record * > (a);
const struct Record arg2 = *static_cast<const struct Record * > (b);

if (arg1.grade > arg2.grade) return 1;
if (arg1.grade < arg2.grade) return -1;
if (arg1.id > arg2.id) return 1;
return -1;
});
}

void sortByTwo(struct Record *records, int n) {
qsort(records, n, sizeof(records[0]), [](const void *a,
const void *b) {
const struct Record arg1 = *static_cast<const struct Record * > (a);
const struct Record arg2 = *static_cast<const struct Record * > (b);

if (strcmp(arg1.name, arg2.name) > 0) return 1;
if (strcmp(arg1.name, arg2.name) < 0) return -1;
if (arg1.id > arg2.id) return 1;
return -1;
});
}

void sortByOne(struct Record *records, int n) {
qsort(records, n, sizeof(records[0]), [](const void *a,
const void *b) {
const struct Record arg1 = *static_cast<const struct Record * > (a);
const struct Record arg2 = *static_cast<const struct Record * > (b);

if (arg1.id > arg2.id) return 1;
return -1;
});
}

int main() {
int n = 0, c = 0;
scanf("%d %d", &n, &c);
struct Record *records = new struct Record[n];
for (int i = 0; i < n; i++) {
scanf("%d %s %d", &records[i].id, records[i].name, &records[i].grade);
}
switch (c) {
case 1:
sortByOne(records, n);
break;
case 2:
sortByTwo(records, n);
break;
default:
sortByThree(records, n);
break;
}

for (int i = 0; i < n; i++) {
printf("%06d %s %d\n", records[i].id, records[i].name, records[i].grade);
}

delete[] records;
return 0;
}