PAT 甲级 1012 The Best Rank(25 分) C++版

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student. For example, The grades of CME and A - Average of 4 students are given as the following:

StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of CM and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space. The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority. If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

对全体学生按C、M、E、A排4次序,得到四个排名,使用map记录最后一次排完序的学生在数组中的下标位置。给出一个学生的id,如果这个id不在map中,输入N/A,否则通过map找到学生的位置,在print_rank函数中打印学生C、M、E、A的最好成绩。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <map>
#include <string>

using namespace std;

struct student {
char id[7];
int score[4], rank[4];
};

bool cmp_0(student a, student b) {
return a.score[0] > b.score[0];
}

bool cmp_1(student a, student b) {
return a.score[1] > b.score[1];
}

bool cmp_2(student a, student b) {
return a.score[2] > b.score[2];
}

bool cmp_3(student a, student b) {
return a.score[3] > b.score[3];
}

void print_rank(student s) {
int rank = s.rank[0], index = 0;
for (int i = 1; i <= 3; i++) {
if (rank > s.rank[i]) {
index = i;
rank = s.rank[i];
}
}
printf("%d ", rank);
switch (index) {
case 0:
printf("A\n");
break;
case 1:
printf("C\n");
break;
case 2:
printf("M\n");
break;
case 3:
printf("E\n");
break;
}
}

int main() {
int n = 0, m = 0;
scanf("%d %d", &n, &m);
struct student *students = new struct student[n];
for (int i = 0; i < n; i++) {
scanf("%s %d %d %d", students[i].id, &students[i].score[1], &students[i].score[2], &students[i].score[3]);
students[i].score[0] = (students[i].score[1] + students[i].score[2] + students[i].score[3]) / 3.0 + 0.5;
}

// sort by C Programming Language
sort(students, students + n, cmp_1);
for (int i = 0; i < n; i++) {
students[i].rank[1] = i + 1;
if (i != 0 && students[i].score[1] == students[i - 1].score[1]) {
students[i].rank[1] = students[i - 1].rank[1];
}
}

// sort by Mathematics
sort(students, students + n, cmp_2);
for (int i = 0; i < n; i++) {
students[i].rank[2] = i + 1;
if (i > 0 && students[i].score[2] == students[i - 1].score[2]) {
students[i].rank[2] = students[i - 1].rank[2];
}
}

// sort by English
sort(students, students + n, cmp_3);
for (int i = 0; i < n; i++) {
students[i].rank[3] = i + 1;
if (i > 0 && students[i].score[3] == students[i - 1].score[3]) {
students[i].rank[3] = students[i - 1].rank[3];
}
}

// sort by Average
sort(students, students + n, cmp_0);
map<string, int> position;
for (int i = 0; i < n; i++) {
position[students[i].id] = i + 1;
students[i].rank[0] = i + 1;
if (i > 0 && students[i].score[0] == students[i - 1].score[0]) {
students[i].rank[0] = students[i - 1].rank[0];
}
}

for (int i = 0; i < m; i++) {
char id[7];
scanf("%s", id);
if (position[id] == 0) {
printf("N/A\n");
} else {
print_rank(students[position[id] - 1]);
}
}
delete[] students;
return 0;
}