请编写程序,找出一段给定文字中出现最频繁的那个英文字母。
输入格式:
输入在一行中给出一个长度不超过1000的字符串。字符串由ASCII码表中任意可见字符及空格组成,至少包含1个英文字母,以回车结束(回车不算在内)。
输出格式:
在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。
输入样例:
This is a simple TEST. There ARE numbers and other symbols 1&2&3………..
输出样例:
e 7
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38
| import java.util.Scanner;
public class Main {
public static void main(String[] args) { Scanner in = new Scanner(System.in);
String string = in.nextLine();
int[] array = new int[26]; for (int i = 0; i < string.length(); i++) { char c = string.charAt(i);
if (c >= 'a' && c <= 'z') { array[c - 'a']++; } else if (c >= 'A' && c <= 'Z') { array[c - 'A']++; } else { } }
in.close();
int maxIndex = 0; for (int i = 1; i < array.length; i++) { if (array[i] > array[maxIndex]) { maxIndex = i; } }
System.out.println((char) (maxIndex + 'a') + " " + array[maxIndex]); }
}
|