PAT 甲级 1146 Topological Order(25 分)

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to “NOT a topological order”. The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4

题意:给出一个有向图,再给出一个所有结点排列的序列,判断这个序列是否是这个有向图的拓扑排序序列。 解题思路:拓扑排序是输出有向图中入度的结点,并将这个结点指向的结点入度减1,循环输出,直到所有结点入度为0

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
#include <cstdio>
#include <set>
#include <vector>

using namespace std;

vector<set<int>> vs(1010);

bool is_topological(int *query, int n) {
int *in = new int[n + 1];
for (int i = 1; i <= n; i++) {
in[i] = vs[i].size();
}

for (int i = 0; i < n; i++) {
if (in[query[i]] != 0) return false;
for (int j = 1; j <= n; j++) {
if (vs[j].find(query[i]) != vs[j].end()) {
in[j]--;
}
}
}
return true;
}

int main() {
int n = 0, m = 0, start = 0, end = 0, k = 0;
scanf("%d %d", &n, &m);
for (int i = 0; i < m; i++) {
scanf("%d %d", &start, &end);
vs[end].insert(start);
}
scanf("%d", &k);
vector<int> ans;
for (int i = 0; i < k; i++) {
int *query = new int[n + 1];
for (int j = 0; j < n; j++) {
scanf("%d", &query[j]);
}
if (!is_topological(query, n)) {
ans.push_back(i);
}
delete[] query;
}
printf("%d", ans[0]);
for (int i = 1; i < ans.size(); i++) {
printf(" %d", ans[i]);
}
return 0;
}