PAT 甲级 1147 Heaps(30 分) C++版

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure) ) Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree’s postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

题意:给出一棵完全二叉树的层序序列,判断它是最大堆(父亲结点大于等于孩子结点)、最小堆(父亲节点小于等于孩子结点)或者不是堆,并输出这棵树的后序遍历序列。 解题思路:对于每个结点,判断它和左右孩子的大小,如果它比左右孩子都大,则是最大堆;如果它比左右孩子都小,则是最小堆;否则它就不是堆。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
#include <cstdio>

// post order traversal sequence
void print_post_order(int *arr, int n, int cur) {
if (cur > n) return;
int left_child = 2 * cur, right_child = 2 * cur + 1;
print_post_order(arr, n, left_child);
print_post_order(arr, n, right_child);
if (cur != 1) printf("%d ", arr[cur]);
}

bool min_heap(int *arr, int n, int cur) {
if (cur >= n) return true;
int left_child = cur * 2, right_child = cur * 2 + 1;
if (right_child <= n) {
if (arr[left_child] >= arr[cur] && arr[right_child] >= arr[cur]) {
return min_heap(arr, n, left_child) && min_heap(arr, n, right_child);
}
} else if (left_child <= n) {
if (arr[left_child] >= arr[cur]) {
return min_heap(arr, n, left_child) && min_heap(arr, n, right_child);
}
} else {
return true;
}
return false;
}

bool max_heap(int *arr, int n, int cur) {
if (cur >= n) return true;
int left_child = cur * 2, right_child = cur * 2 + 1;
if (right_child <= n) {
if (arr[left_child] <= arr[cur] && arr[right_child] <= arr[cur]) {
return max_heap(arr, n, left_child) && max_heap(arr, n, right_child);
}
} else if (left_child <= n) {
if (arr[left_child] <= arr[cur]) {
return max_heap(arr, n, left_child) && max_heap(arr, n, right_child);
}
} else {
return true;
}
return false;
}

int main() {
int m = 0, n = 0;
scanf("%d %d", &m, &n);
for (int i = 0; i < m; i++) {
int *arr = new int[1030];
for (int j = 1; j <= n; j++) {
scanf("%d", &arr[j]);
}
if (max_heap(arr, n, 1)) {
printf("Max Heap\n");
} else if (min_heap(arr, n, 1)) {
printf("Min Heap\n");
} else {
printf("Not Heap\n");
}
print_post_order(arr, n, 1);
printf("%d\n", arr[1]);
delete[] arr;
}
return 0;
}