PAT 1142. Maximal Clique (25)

clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory)) Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv (<= 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv. After the graph, there is another positive integer M (<= 100). Then M lines of query follow, each first gives a positive number K (<= Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:

For each of the M queries, print in a line “Yes” if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print “Not Maximal”; or if it is not a clique at all, print “Not a Clique”.

Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1

Sample Output:

Yes
Yes
Yes
Yes
Not Maximal
Not a Clique

满足两两之间有边连接的顶点的集合,被称为该无向图的团。 因为要频繁的判断两个点是否连通,所以使用邻接矩阵来存储。 judge函数即判断给出的一系列是是否是团、以及最大团。 judge函数的第一块for循环是判断给出的点本身是否两两相通,如果存在不相通的两个点,则它不是一个团。 judge函数的第二块for循环是判断是否在图中一个其他结点与给出的结点序列中的所有结点都相通。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
#include <iostream>

int vt[210][210];

void judge(int *arr, int n, int nv) {
for (int i = 0; i < n; i++) {
for (int j = i + 1; j < n; j++) {
if (!vt[arr[i]][arr[j]]) {
printf("Not a Clique\n");
return;
}
}
}
for (int i = 1; i <= nv; i++) {
int cnt = 0;
for (int j = 0; j < n; j++) {
if (vt[i][arr[j]]) {
cnt++;
}
}
if (cnt == n) {
printf("Not Maximal\n");
return;
}
}
printf("Yes\n");
}

int main() {
int nv = 0, ne = 0, a = 0, b = 0, m = 0, k = 0;
scanf("%d %d", &nv, &ne);
for (int i = 0; i < ne; i++) {
scanf("%d %d", &a, &b);
vt[a][b] = vt[b][a] = 1;
}
scanf("%d", &m);
for (int i = 0; i < m; i++) {
scanf("%d", &k);
int *arr = new int[k];
for (int j = 0; j < k; j++) {
scanf("%d", &arr[j]);
}
judge(arr, k, nv);
}
return 0;
}