PAT 1141. PAT Ranking of Institutions (25)

After each PAT, the PAT Center will announce the ranking of institutions based on their students’ performances. Now you are asked to generate the ranklist.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=105), which is the number of testees. Then N lines follow, each gives the information of a testee in the following format: ID Score School where “ID” is a string of 6 characters with the first one representing the test level: “B” stands for the basic level, “A” the advanced level and “T” the top level; “Score” is an integer in [0, 100]; and “School” is the institution code which is a string of no more than 6 English letters (case insensitive). Note: it is guaranteed that “ID” is unique for each testee.

Output Specification:

For each case, first print in a line the total number of institutions. Then output the ranklist of institutions in nondecreasing order of their ranks in the following format: Rank School TWS Ns where “Rank” is the rank (start from 1) of the institution; “School” is the institution code (all in lower case); “TWS” is the total weighted score which is defined to be the integer part of “ScoreB/1.5 + ScoreA + ScoreT*1.5”, where “ScoreX” is the total score of the testees belong to this institution on level X; and “Ns” is the total number of testees who belong to this institution. The institutions are ranked according to their TWS. If there is a tie, the institutions are supposed to have the same rank, and they shall be printed in ascending order of Ns. If there is still a tie, they shall be printed in alphabetical order of their codes.

Sample Input:

10
A57908 85 Au
B57908 54 LanX
A37487 60 au
T28374 67 CMU
T32486 24 hypu
A66734 92 cmu
B76378 71 AU
A47780 45 lanx
A72809 100 pku
A03274 45 hypu

Sample Output:

5
1 cmu 192 2
1 au 192 3
3 pku 100 1
4 hypu 81 2
4 lanx 81 2

常规题,使用map映射校名与总分以及人数,之后放到数组里面进行排序输出。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
#include <iostream>
#include <algorithm>
#include <string>
#include <map>
#include <cctype>

using namespace std;

string tolow(string name) {
for (int i = 0; i < name.size(); i++)
if (isupper(name[i]))
name[i] = tolower(name[i]);
return name;
}

struct school {
string name;
int tws, ns;
} schools[100010];

int main() {
int n = 0, score = 0, rank = 1, index = 0;
scanf("%d", &n);
char id[8], name[8];
map<string, double> mtws;
map<string, int> mns;
for (int i = 0; i < n; i++) {
scanf("%s %d %s", id, &score, name);
string lowname = tolow(name);
if (id[0] == 'A') {
mtws[lowname] += score;
} else if (id[0] == 'B') {
mtws[lowname] += score / 1.5;
} else if (id[0] == 'T') {
mtws[lowname] += score * 1.5;
}
mns[lowname]++;
}
printf("%lu\n", mtws.size());
for (auto it = mtws.begin(); it != mtws.end(); it++) {
schools[index++] = school{it->first, (int) it->second, mns[it->first]};
}
sort(schools, schools + index, [](school a, school b) {
return a.tws == b.tws ? (a.ns == b.ns ? a.name < b.name : a.ns < b.ns) : a.tws > b.tws;
});
for (int i = 0; i < index; i++) {
if (i > 0 && schools[i].tws != schools[i - 1].tws)
rank = i + 1;
printf("%d %s %d %d\n", rank, schools[i].name.c_str(), schools[i].tws, schools[i].ns);
}
return 0;
}