PAT 甲级 1007. Maximum Subsequence Sum (25) C++版

Given a sequence of K integers { N1, N2, …, NK }. A continuous subsequence is defined to be { Ni, Ni+1, …, Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20. Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

记tsum为部分和,sum为结果和。从下标0开始,部分和累加当前下标的数组值,如果这个部分和小于0,则重置状态(tsum = 0, tstart=i+1)。如果这个部分和比结果和要大,就需要更新结果和的值和状态并记录当前位置为结果和的最终位置。all_neg表示数组中的值是否都是负数。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
#include <cstdio>

int main() {
int k = 0, sum = -1, tsum = 0, start = 0, tstart = 0, end = 0, all_neg = 1;
scanf("%d", &k);
int *num = new int[k];
for (int i = 0; i < k; i++) {
scanf("%d", &num[i]);
if (num[i] >= 0) all_neg = 0;
tsum += num[i];
if (tsum < 0) {
tsum = 0;
tstart = i + 1;
} else if (tsum > sum) {
sum = tsum;
end = i;
start = tstart;
}
}
if (all_neg) printf("0 %d %d", num[0], num[k - 1]);
else printf("%d %d %d", sum, num[start], num[end]);
return 0;
}