PAT 甲级 1001. A+B Format (20) C++版

Calculate a + b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991

将两个数的和格式化输出,由于两个数的和没有超过整型范围,所以可以直接用整型来处理。如果一个数的位数低于4位数,则不需要格式化;否则,可以把这个数的最低三位截掉输出,并处理前面剩下的几位数。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
#include <cstdio>
#include <cstdlib>

void format(int x) {
if (abs(x) < 1000) {
printf("%d", x);
return;
}
format(x / 1000);
printf(",%03d", abs(x % 1000));
}

int main() {
int a = 0, b = 0;
scanf("%d %d", &a, &b);
format(a + b);
return 0;
}