如果你是哈利·波特迷,你会知道魔法世界有它自己的货币系统 —— 就如海格告诉哈利的:“十七个银西可(Sickle)兑一个加隆(Galleon),二十九个纳特(Knut)兑一个西可,很容易。”现在,给定哈利应付的价钱P和他实付的钱A,你的任务是写一个程序来计算他应该被找的零钱。
输入格式:
输入在1行中分别给出P和A,格式为“Galleon.Sickle.Knut”,其间用1个空格分隔。这里Galleon是[0, 107]区间内的整数,Sickle是[0, 17)区间内的整数,Knut是[0, 29)区间内的整数。
输出格式:
在一行中用与输入同样的格式输出哈利应该被找的零钱。如果他没带够钱,那么输出的应该是负数。
输入样例1:
10.16.27 14.1.28
输出样例1:
3.2.1
输入样例2:
14.1.28 10.16.27
输出样例2:
-3.2.1
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67
| import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner in = new Scanner(System.in);
Coin p = new Coin(in.next().split("[.]")); Coin a = new Coin(in.next().split("[.]")); in.close();
Coin result = new Coin(); if (p.galleon > a.galleon) { System.out.print("-");
if (p.kunt < a.kunt) { p.kunt += 29; p.sickle--; } result.kunt = p.kunt - a.kunt;
if (p.sickle < a.sickle) { p.sickle += 17; p.galleon--; } result.sickle = p.sickle - a.sickle; result.galleon = p.galleon - a.galleon; } else { if (p.kunt > a.kunt) { a.kunt += 29; a.sickle--; } result.kunt = a.kunt - p.kunt;
if (p.sickle > a.sickle) { a.sickle += 17; a.galleon--; } result.sickle = a.sickle - p.sickle; result.galleon = a.galleon - p.galleon; }
System.out.print(result.galleon + "." + result.sickle + "." + result.kunt); }
}
class Coin { int galleon; int sickle; int kunt;
public Coin() { this.galleon = this.sickle = this.kunt = 0; }
public Coin(String[] coin) { this.galleon = Integer.parseInt(coin[0]); this.sickle = Integer.parseInt(coin[1]); this.kunt = Integer.parseInt(coin[2]);
} }
|