PAT 乙级 1029. 旧键盘(20) Java版

旧键盘上坏了几个键,于是在敲一段文字的时候,对应的字符就不会出现。现在给出应该输入的一段文字、以及实际被输入的文字,请你列出肯定坏掉的那些键。

输入格式:

输入在2行中分别给出应该输入的文字、以及实际被输入的文字。每段文字是不超过80个字符的串,由字母A-Z(包括大、小写)、数字0-9、以及下划线“_”(代表空格)组成。题目保证2个字符串均非空。

输出格式:

按照发现顺序,在一行中输出坏掉的键。其中英文字母只输出大写,每个坏键只输出一次。题目保证至少有1个坏键。

输入样例:

7_This_is_a_test
_hs_s_a_es

输出样例:

7TI

此处,谢谢@xiaorong61提供的代码 将两次的输入都转化为大写的,使用字符串的indexOf快速查找。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
import java.util.Scanner;

public class Main {

public static void main(String[] args) {
Scanner in = new Scanner(System.in);
String should = in.nextLine().toUpperCase();
String reality = in.nextLine().toUpperCase();
in.close();
String result = "";
for (int i = 0; i < should.length(); i++)
if (reality.indexOf(should.charAt(i)) == -1 && result.indexOf(should.charAt(i)) == -1)
result += should.charAt(i);
System.out.println(result);
}
}