旧键盘上坏了几个键,于是在敲一段文字的时候,对应的字符就不会出现。现在给出应该输入的一段文字、以及坏掉的那些键,打出的结果文字会是怎样?
输入格式:
输入在2行中分别给出坏掉的那些键、以及应该输入的文字。其中对应英文字母的坏键以大写给出;每段文字是不超过105个字符的串。可用的字符包括字母[a-z, A-Z]、数字0-9、以及下划线“_”(代表空格)、“,”、“.”、“-”、“+”(代表上档键)。题目保证第2行输入的文字串非空。 注意:如果上档键坏掉了,那么大写的英文字母无法被打出。
输出格式:
在一行中输出能够被打出的结果文字。如果没有一个字符能被打出,则输出空行。
输入样例:
7+IE.
7_This_is_a_test.
输出样例:
_hs_s_a_tst
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46
| #include <iostream> #include <string> #include <set> #include <cctype>
using namespace std;
int main() { string badKeyInput, testKey;
getline(cin, badKeyInput); getline(cin, testKey);
bool noShiftKey = true; set<char> s; for (int i = 0; i < badKeyInput.length(); i++) { char c = badKeyInput[i]; if (c == '+') { noShiftKey = false; } s.insert(c); s.insert(tolower(c)); }
if (noShiftKey) {
for (int i = 0; i < testKey.length(); i++) { char c = testKey[i]; if (s.count(c) == 0) { cout << c; } } } else {
for (int i = 0; i < testKey.length(); i++) { char c = testKey[i]; if (!isupper(c)) { if (s.count(c) == 0) { cout << c; } } } }
return 0; }
|