PAT 乙级 1018. 锤子剪刀布 (20) C++版

大家应该都会玩“锤子剪刀布”的游戏:两人同时给出手势,胜负规则如图所示:

现给出两人的交锋记录,请统计双方的胜、平、负次数,并且给出双方分别出什么手势的胜算最大。

输入格式:

输入第1行给出正整数N(<=105),即双方交锋的次数。随后N行,每行给出一次交锋的信息,即甲、乙双方同时给出的的手势。C代表“锤子”、J代表“剪刀”、B代表“布”,第1个字母代表甲方,第2个代表乙方,中间有1个空格。

输出格式:

输出第1、2行分别给出甲、乙的胜、平、负次数,数字间以1个空格分隔。第3行给出两个字母,分别代表甲、乙获胜次数最多的手势,中间有1个空格。如果解不唯一,则输出按字母序最小的解。

输入样例:

10
C J
J B
C B
B B
B C
C C
C B
J B
B C
J J

输出样例:

5 3 2
2 3 5
B B

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
#include <iostream>

using namespace std;

int main() {
int n;
cin >> n;

int *states = new int[3];
int JB = 0, JC = 0, JJ = 0;
int YB = 0, YC = 0, YJ = 0;
for (int i = 0; i < n; i++) {
char a, b;
cin >> a >> b;
if (a == 'B') {
if (b == 'B') {
states[1]++;
} else if (b == 'C') {
states[0]++;
JB++;
} else {
states[2]++;
YJ++;
}
} else if (a == 'C') {
if (b == 'B') {
states[2]++;
YB++;
} else if (b == 'C') {
states[1]++;
} else {
states[0]++;
JC++;
}
} else {
// a == 'J'
if (b == 'B') {
states[0]++;
JJ++;
} else if (b == 'C') {
states[2]++;
YC++;
} else {
states[1]++;
}
}
}

cout << states[0] << " " << states[1] << " " << states[2] << endl;
cout << states[2] << " " << states[1] << " " << states[0] << endl;

int max = JB;
char symbol = 'B';
if (max < JC) {
max = JC;
symbol = 'C';
}
if (max < JJ) {
symbol = 'J';
}

cout << symbol << " ";

max = YB;
symbol = 'B';
if (max < YC) {
symbol = 'C';
max = YC;
}
if (max < YJ) {
symbol = 'J';
}
cout << symbol;

return 0;
}