PAT 甲级 1014. Waiting in Line (30) C++版

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customer[i] will take T[i] minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done. For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1 is served at window1 while customer2 is served at window2. Customer3 will wait in front of window1 and customer4 will wait in front of window2. Customer5 will wait behind the yellow line. At 08:01, customer1 is done and customer5 enters the line in front of window1 since that line seems shorter now. Customer2 will leave at 08:02, customer4 at 08:06, customer3 at 08:07, and finally customer5 at 08:10.

Input

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries). The next line contains K positive integers, which are the processing time of the K customers. The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output “Sorry” instead.

Sample Input

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output

08:07
08:06
08:10
17:00
Sorry

在K个顾客中,前M * N个顾客是在黄线以内的,在窗口的排列顺序如:1号窗口分别是1, 1 + N, 1 + 2N,…, 1+ N * (M - 1);2号窗口是2, 2 + N, 2 + 2N,…, 2 + N * (M - 1); N号窗口是:N, N + N, N + 2N,…,N + N (M - 1)。 在后K - M*N个顾客组成的队列中,队列中第一个顾客总是排在所有窗口前第一个顾客先结束的窗口。 对顾客建立一个结构体custmer,分别包含顾客需要的服务时间st和顾客离开的时间lt,由此可以得到顾客开始被服务的时间为lt - st。如果lt - st >= 540即表示顾客在17点之后被服务,应该输出的是Sorry. popEarlyFormWins函数总是将所有窗口当中,最早结束的那个顾客从窗口队列中弹出,并返回这个窗口的下标。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
#include <cstdio>
#include <vector>
#include <queue>

using namespace std;

struct custmer {
int st, lt; // service and lift time
};

vector<custmer> custmers;
vector<queue<int>> wins;

int popEarlyFormWins() {
int early = 0;
for (int i = 1; i < wins.size(); i++) {
if (custmers[wins[i].front()].lt < custmers[wins[early].front()].lt) {
early = i;
}
}

wins[early].pop();
return early;
}

int main() {
int n = 0, m = 0, k = 0, q = 0;
scanf("%d %d %d %d", &n, &m, &k, &q);
custmers.resize(k);
for (int i = 0; i < k; i++) {
scanf("%d", &custmers[i].st);
}

wins.resize(n);
for (int i = 0; i < m * n && i < k; i++) {
if (i < n) {
custmers[i].lt = custmers[i].st;
} else {
int index = wins[i % n].back();
custmers[i].lt = custmers[index].lt + custmers[i].st;
}
wins[i % n].push(i);
}

for (int i = m * n; i < k; i++) {
int early = popEarlyFormWins();
int index = wins[early].back();
custmers[i].lt = custmers[index].lt + custmers[i].st;
wins[early].push(i);
}

int index = 0;
for (int i = 0; i < q; i++) {
scanf("%d", &index);
if (custmers[index - 1].lt - custmers[index - 1].st >= 540) {
printf("Sorry\n");
} else {
printf("%02d:%02d\n", custmers[index - 1].lt / 60 + 8, custmers[index - 1].lt % 60);
}
}

return 0;
}