PAT 乙级 1045. 快速排序(25) C++版

著名的快速排序算法里有一个经典的划分过程:我们通常采用某种方法取一个元素作为主元,通过交换,把比主元小的元素放到它的左边,比主元大的元素放到它的右边。 给定划分后的N个互不相同的正整数的排列,请问有多少个元素可能是划分前选取的主元? 例如给定N = 5, 排列是1、3、2、4、5。则:  

  • 1的左边没有元素,右边的元素都比它大,所以它可能是主元;
  • 尽管3的左边元素都比它小,但是它右边的2它小,所以它不能是主元;
  • 尽管2的右边元素都比它大,但其左边的3比它大,所以它不能是主元;
  • 类似原因,4和5都可能是主元。因此,有3个元素可能是主元。

输入格式:

输入在第1行中给出一个正整数N(<= 105); 第2行是空格分隔的N个不同的正整数,每个数不超过109。

输出格式:

在第1行中输出有可能是主元的元素个数;在第2行中按递增顺序输出这些元素,其间以1个空格分隔,行末不得有多余空格。

输入样例:

5
1 3 2 4 5

输出样例:

3
1 4 5

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
#include <iostream>
#include <algorithm>
#include <vector>
#include <cstdlib>

using namespace std;

int cmp(const void *a, const void *b) {
int arg1 = *static_cast<const int *>(a);
int arg2 = *static_cast<const int *>(b);

if (arg1 < arg2) return -1;
if (arg1 > arg2) return 1;
return 0;
}

int main() {
int n = 0;
scanf("%d", &n);
int *array = new int[n];
int *sorted = new int[n];
for (int i = 0; i < n; i++) {
scanf("%d", &array[i]);
sorted[i] = array[i];
}

qsort(sorted, n, sizeof(int), cmp);
vector<int> v;
int max = -1;
for (int i = 0; i < n; i++) {
if (array[i] > max) {
max = array[i];
}

if (sorted[i] == array[i] && sorted[i] == max) {
v.push_back(array[i]);
}
}

cout << v.size() << endl;
for (int i = 0; i < v.size(); i++) {
if (i == 0) {
cout << v[0];
} else {
cout << " " << v[i];

}
}
cout << endl;
return 0;
}