PAT 乙级 1028. 人口普查(20) C++版

某城镇进行人口普查,得到了全体居民的生日。现请你写个程序,找出镇上最年长和最年轻的人。 这里确保每个输入的日期都是合法的,但不一定是合理的——假设已知镇上没有超过200岁的老人,而今天是2014年9月6日,所以超过200岁的生日和未出生的生日都是不合理的,应该被过滤掉。

输入格式:

输入在第一行给出正整数N,取值在(0, 105];随后N行,每行给出1个人的姓名(由不超过5个英文字母组成的字符串)、以及按“yyyy/mm/dd”(即年/月/日)格式给出的生日。题目保证最年长和最年轻的人没有并列。

输出格式:

在一行中顺序输出有效生日的个数、最年长人和最年轻人的姓名,其间以空格分隔。

输入样例:

5
John 2001/05/12
Tom 1814/09/06
Ann 2121/01/30
James 1814/09/05
Steve 1967/11/20

输出样例:

3 Tom John

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
#include <iostream>

using namespace std;

struct People {
string name;
int year;
int month;
int day;
};

bool isValid(struct People p) {
if (p.year > 2014 || p.year < 1814) {
return false;
} else {
if (p.year == 2014) {
if (p.month < 9) {
return true;
} else if (p.month > 9) {
return false;
} else {
if (p.day <= 6) {
return true;
} else {
return false;
}
}
} else if (p.year == 1814) {
if (p.month > 9) {
return true;
} else if (p.month < 9) {
return false;
} else {
if (p.day >= 6) {
return true;
} else {
return false;
}
}
} else {
return true;
}
}
}

int compare(struct People man1, struct People man2) {
if (man1.year < man2.year) {
return 1;
} else if (man1.year == man2.year) {
if (man1.month < man2.month) {
return 1;
} else if (man1.month == man2.month) {
if (man1.day < man2.day) {
return 1;
} else if (man1.day == man2.day) {
return 0;
} else {
return -1;
}
} else {
return -1;
}
} else {
return -1;
}
return 0;
}

int main() {
int n = 0;
cin >> n;
int valid = 0;
struct People max, min;
max.year = 2014;
max.month = 9;
max.day = 6;
min.year = 1814;
min.month = 9;
min.day = 6;
for (int i = 0; i < n; i++) {
struct People p;
cin >> p.name;
scanf("%d/%d/%d", &p.year, &p.month, &p.day);

if (isValid(p)) {
max = compare(max, p) > 0 ? max : p;
min = compare(p, min) > 0 ? min : p;
valid++;
}
}

if (valid != 0) {
cout << valid << " " << max.name << " " << min.name << endl;
} else {
cout << 0;
}
return 0;
}