PAT 1128. N Queens Puzzle (20)

The “eight queens puzzle” is the problem of placing eight chess queens on an 8×8 chessboard so that no two queens threaten each other. Thus, a solution requires that no two queens share the same row, column, or diagonal. The eight queens puzzle is an example of the more general N queens problem of placing N non-attacking queens on an N×N chessboard. (From Wikipedia - “Eight queens puzzle”.) Here you are NOT asked to solve the puzzles. Instead, you are supposed to judge whether or not a given configuration of the chessboard is a solution. To simplify the representation of a chessboard, let us assume that no two queens will be placed in the same column. Then a configuration can be represented by a simple integer sequence (Q1, Q2, …, QN), where Qi is the row number of the queen in the i-th column. For example, Figure 1 can be represented by (4, 6, 8, 2, 7, 1, 3, 5) and it is indeed a solution to the 8 queens puzzle; while Figure 2 can be represented by (4, 6, 7, 2, 8, 1, 9, 5, 3) and is NOT a 9 queens’ solution.

  #### Input Specification:

Each input file contains several test cases. The first line gives an integer K (1 < K <= 200). Then K lines follow, each gives a configuration in the format “N Q1 Q2 … QN”, where 4 <= N <= 1000 and it is guaranteed that 1 <= Qi <= N for all i=1, …, N. The numbers are separated by spaces.

Output Specification:

For each configuration, if it is a solution to the N queens problem, print “YES” in a line; or “NO” if not.

Sample Input:

4
8 4 6 8 2 7 1 3 5
9 4 6 7 2 8 1 9 5 3
6 1 5 2 6 4 3
5 1 3 5 2 4

Sample Output:

YES
NO
NO
YES

题目大意中给出的例子和图的关系我是没怎么看懂的。但N皇后问题,题目的陈述中已经有了,及相同行,相同列和对角线上面不能有其他皇后。row数组用来判断有每一行是否仅有一个皇后。isSameDiagonal函数判断是否有两个皇后在一条对角线上,这里我用的方法是斜率,即(横坐标差的绝对值)除(纵坐标差的绝对值)=1的两个点在一条直线上。这样就可以判断是否为N皇后问题了。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
#include <cmath>
#include <cstdio>

using namespace std;

bool isSameDiagonal(int *q, int n, int current) { // same diagonal
for (int i = 1; i < current; i++) {
if (fabs(i - current) / fabs(q[i] - q[current]) == 1) {
return false;
}
}
return true;
}

bool isNQueues(int *q, int n) {
bool *row = new bool[n + 1]; // same row
for (int i = 2; i <= n; i++) {
row[q[i - 1]] = true;
if (row[q[i]] || !isSameDiagonal(q, n, i) || fabs(q[i] - q[i - 1]) <= 1) {
return false;
}
}
return true;
}

int main() {
int k = 0;
scanf("%d", &k);
int *q = new int[1010];
for (int c = 0; c < k; c++) {
int n = 0;
scanf("%d", &n);
for (int i = 1; i <= n; i++) {
scanf("%d", &q[i]);
}
if (n >= 4 && isNQueues(q, n)) {
printf("YES\n");
} else {
printf("NO\n");
}
}
return 0;
}